求助:Cloudera cdh 集群配置指定版本的组件

spark

#1

现需要搭建包含指定版本的包含hadoop、hbase、solr、spark、hive、oozie、zookeeper组件的Cloudera cdh 集群。百度与bing过后暂未发现类似问题,有遇到过此类问题的朋友没? 比如hadoop是2.7.2;hbase是1.0.2;hive是1.3.0;zookeeper是3.5.1;spark是1.5.1;solr是5.3.1;oozie是4.2.0。 这个问题是否可以转换为近似的版本替代?或者有更好的解决思路与方案(ambri支持不?) 生产环境是上述版本,目前需要搭建测试环境,生产的是华为的, 测试的想搭建为cdh的。


#2

官网,应该有版本支持说明~


#3

你的意思指的是选择一个cdh版本,然后再选择与这个版本一样的经过编译后的指定版本的各个组件,然后再安装?


#4

是的,一般都是以一个主的稳定版,再搭配其他版本,要不后面会有好多版本兼容性不好的问题


#5

采用了您的建议,手动配置各个组件,目前已完成安装上述组件。


#6

好,非常赞,:grinning: